Nissan Cube Life - Nissan Cube Car Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I just added a amp/subwoofer to my system and removed the radio from the dash to wire everything up. When I put everything back together the airbag warning light started blinking and the "passenger side airbag off" light under the radio is always on. I didn't touch anything involved in the airbag system, I just disconnected the radio and I have no idea whats wrong. Is there anyway to get the light to shut off?
 

·
Registered
Joined
·
108 Posts
This happened to me and this is how I got it to turn off...

1. Turn the key from off to on.

2. Watch the airbag light closely. It will stay on for a few secs. and then as soon as it blinks off (the start of the flashing), turn the key off instantly.

3. Count to 5 (1 Mississippi, 2 Mississippi . . . .)

4. Repeat steps 1-3 two more times until you have done the cycle three times.

5. Now turn the key on and watch the light. It will start blinking in a different, slower manner. This is diagnostic mode. You can watch this for a little while, no hurry.

6. Now turn the key off again, Count to 5 like in step 3 again, and turn back on. If the procedure worked, the airbag light will not be flashing.



You unplugged the passanger airbag indicators and turned on the ignition while it's unpluged. it's a common mistake since alot of people have a habit of turning on the ignition to test the product installed before putting everything back together
 

·
Registered
Joined
·
108 Posts
Wish you luck...let me know if it works...I considered the push button start but it really cost more money all the way around for it...I'm going to put a Scytek remote start and alarm on my cube and its more complicated with a push start...I figured if I can start my car 1/2 mile away then how good is a push button...
 

·
Registered
Joined
·
46 Posts
I had the same problem after installing my new stereo & it was only 1 hour after taking the delivery. I drove back to the dealer and they had it reset for me without charge :D Try to ask nicely to the service adviser, they will usually do it free for the first time. I actually promised them it won't happen again & they were laughing at me that the original stereo is in the car for less than an hour. Actually I'd just used it for less than 15mins -- from the dealer to my garage.
Hope your dealer will give you a free one.
Cheers
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
I tried jasonbillups method he listed above and it worked great. It took a couple of tries because it's hard to get the timing down with the push start ignition. I also found out I needed to reset the drivers side window because the auto-up feature wouldn't work since I disconnected the battery. I used to have an 88 Toyota Supra and it didn't have any of these systems so this is a little foreign for me. My wife told me to just leave the radio alone cause I was gonna screw up the car and since I never listen to her anyway I still did it. When that airbag light came on, going on a roadtrip with her today would have been a miserable experience if she spotted it. Thanks guys.
 

·
Registered
Joined
·
46 Posts
Just installed my Sirius Tuner today and the same thing happened to me!! Fortunately after 15 years of doing professional installs I knew what to do, but at first I was like "what the heck did I do"? Cycled the key 5 times and VIOLA good to go, wish I would have seen this post before as I could have commented earlier, Received my light up door sills today and putting them in tomorrow, I LOVE MY CUBE!!!
 
1 - 7 of 7 Posts
Top