Nissan Cube Life - Nissan Cube Car Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter · #1 ·
Yesterday,I've finally got a chance to put things back together and able to start the car and stereo runs fine BUT.....the airbag warning light is blinking constantly.
Any one encounter this? Solution?

Here's what I did over the past few weeks:
- Routed power to amp.
- removed front passenger seat and mount amp there
- replaced OEM speakers with aftermarktet
- removed # of panels and center console for amp installation

I've tried to look up more info in FSM but not found anything.

Thanks
007
 

·
Registered
Joined
·
161 Posts
miata007 said:
- removed front passenger seat and mount amp there
I'd be suspicious of this step. Wouldn't be the first time people had trouble with the little connectors that are under there. You disconnected the battery before unplugging the air bag right?

Sadly, "usually" you have to get the dealer to clear the code, even if you find the problem.

Best of luck!

Dang
 

·
Moderator
Joined
·
2,084 Posts
Looking for the horns true fuse as it is not listed in the owners manual or service manual and listed in row 2 on the fuse block as #3 ( I am going by memory and may be plus or minus 1) The fuse location was empty.

I also pulled the fuse to the air bag, if it actually was the air bag, as most don't line up, Push button start is on row 2, position 5, but when pulled the vehicle started fine. (what gives right?) The car should not start with no fuse right??

I received no warning light! Usually things in there line up but a blurb in the panel says call your dealer for systems not listed.

So removing the seat I am sceptical on as the issue.
 

·
Moderator
Joined
·
2,084 Posts
CubeRich said:
Did you start the vehicle, with the seat disconnected and removed? If you did.. I guarantee that's the problem.
I know some would say why would you start the car with the seat removed? I am with you on this one! Installing a high powered car stereo you would do it!
 

·
Registered
Joined
·
170 Posts
This was posted by Jason Billups and worked for me as well since I too installed amps under the seats...hope this helps you

This happened to me and this is how I got it to turn off...

1. Turn the key from off to on.

2. Watch the airbag light closely. It will stay on for a few secs. and then as soon as it blinks off (the start of the flashing), turn the key off instantly.

3. Count to 5 (1 Mississippi, 2 Mississippi . . . .)

4. Repeat steps 1-3 two more times until you have done the cycle three times.

5. Now turn the key on and watch the light. It will start blinking in a different, slower manner. This is diagnostic mode. You can watch this for a little while, no hurry.

6. Now turn the key off again, Count to 5 like in step 3 again, and turn back on. If the procedure worked, the airbag light will not be flashing.



You unplugged the passanger airbag indicators and turned on the ignition while it's unpluged. it's a common mistake since alot of people have a habit of turning on the ignition to test the product installed before putting everything back together
 

·
Registered
Joined
·
175 Posts
Q!Cube said:
it's a common mistake since alot of people have a habit of turning on the ignition to test the product installed before putting everything back together
Exactly... now if someone would just clarify my S vs. SL option question...
 

·
Registered
Joined
·
161 Posts
more info

Christine...

The seats are part of the SRS system. When you disconnect the seat, the computer gets an "ambiguous signal", and triggers the light. Did it myself on the smart when testing out the amps I put under my seat (just like Q!Cube).

miata..
To add to Q!Cube's post. If this doesn't cure it, when you get it in diagnostic mode, could the number of fast (1/2 second) blinks. If you use the diagnostic manual it will tell you where the problem is (3 second blink, followed by some number of .5 second blinks for the front air bag system, or two 1.5 second blinks followed by some number of .5 second blinks for the side air bag system.). That will narrow down where to look.

Best of luck!

Dang
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #9 ·
Dang said:
miata007 said:
- removed front passenger seat and mount amp there
I'd be suspicious of this step. Wouldn't be the first time people had trouble with the little connectors that are under there. You disconnected the battery before unplugging the air bag right?

Sadly, "usually" you have to get the dealer to clear the code, even if you find the problem.

Best of luck!

Dang

I did disconnect the battery before removing the seat and connector. However, I did connect the power back and and try out the sound system a few times before putting the seat and connector back on.

I started the engine after I put the seat/connector back together though if that makes any difference.
This is my first audio systen installation.


Christine,
I looked the FSM today and didn't see diagnostic procedure for airbag warning. Can you please point me to the specific sections?
Only saw section that says to let dealer do any work related to airbag.

thanks so much for everyone's input. I will try out procedure someone posted today and get back to you all.

007
 

·
Registered
Joined
·
161 Posts
Hey 007....

I'll chime in for Christine...

On the FSM, go to the PDF module called src.pdf.
Once open, go to page 17.
Pages 17 to 22 describe how to get into diagnostic mode, and what the flashes mean.

Cheers!

Dang
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #11 ·
Hi
I've just tried out the reset procedure and the airbag light went away.

I notice the passenger airbig off warning light is not on. Is that normal?

Just looked at FSM (src section page 14) and found I was looked for:
Status (passenger seat) Passenger air bag Passenger air bag OFF indicator
Air bag warning lamp
Empty Suppress OFF OFF
An object Suppress ON OFF
Child/ child-seat Suppress ON OFF
Adult Enable to deploy OFF OFF
Malfunction Suppress ON Blinking
Zero point reset
Not yet performed (NISSAN
genuine parts only)
Suppress ON Blinking

I will check in the morning if the light will be on if I put a carseat there (passenger side seat -front). if it does, I say my system is operating as normal.
If the light remains off, then there is issue that needs to be resolved.

Thanks
007
 
1 - 11 of 11 Posts
Top