Nissan Cube Life - Nissan Cube Car Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
My gas gauge will go up and down 4-5 bars during a 10 minute drive. It seems to be VERY easily fooled by the slope of the vehicle as it is parked or driven down the road. I have never had a vehicle with such a tempremental gauge. Are all Cube gas gauges like this or is it just mine?
 

·
Registered
Joined
·
135 Posts
Yes, it is starting to tick me off, i fill it up, it does not show full sometimes. I take a short trip and get back in the car and yes it seems to have lost 3 bars. I will not take it to the dealer for this, as those pros said they couldn't do anything to make the speedometer correct (its 4 mph off!), so how could they ever figure out the fuel gauge problem? :mad:
 

·
Registered
Joined
·
179 Posts
I don't notice this and I drive a 3 mile long hill every day. Uphill...both ways...in the snow with no shoes... :roll: Oh wait that was a lecture I had to endure when I was young, anyways there is supposed to be a resistor some where in the sending unit circuit so that the signal changes slowly and doesn't give the false reading. I haven't checked the schematic though. Might ask Nissan about it. 8)
 

·
Moderator
Joined
·
2,084 Posts
back in the day when it was a cork float and a spiral rod that was an issue, with the electronic sampling devices today it should not due this. As fuel is a fluid and sloshes around the sensor can be fooled but mine has never given an up and down reading.

Back in the day you hit the brakes hard and the gauge went empty,full,empty,full, as the fuel sloshed around.
 

·
Registered
Joined
·
119 Posts
I've never had mine gain bars after they disappeared, sounds like you might have a problem with yours.
 

·
Registered
Joined
·
303 Posts
Well I had an issue when filling up. The last bar at the top didn't appear when the nozzle "clicked", meaning it was full. So I took it to the dealer and they found that the fuel sensor was messed up, and they fixed it. Now though, whenever I fill up on gas and its missing only a couple of bars, it doesn't fill up all the way. I guess it has to be at least half empty if not more, for the fuel gage to completely up. I took it back, but they said it was fine.
Somestimes when I park on a little slope or am going uphill/downhill, the gage will lose a bar, but then it gets it back.
 

·
Moderator
Joined
·
2,084 Posts
AFireinsideMyCube said:
Sometimes when I park on a little slope or am going uphill/downhill, the gage will lose a bar, but then it gets it back.
Interesting, sounds like a ghost in the system exists
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #10 ·
Now that I have a few tanks through it, ( I drive a lot ) it appears to do it much more for the first 1/3 of the tank and hardly at all for the last 1/3 of the tank.
 

·
Registered
Joined
·
24 Posts
AFireinsideMyCube said:
Well I had an issue when filling up. The last bar at the top didn't appear when the nozzle "clicked", meaning it was full.........
When I fill up the top bar does not appear if I stop when the pump first shuts off. I can still get quite a bit more gas in the tank if I wait a minute and then start the pump again on the first slow notch. I need to do this two, sometimes three times to get the tank completely full.

I wish this car had just a slighly larger tank - a 290 mile range is about 30 miles shy of what I'm used to.
 

·
Registered
Joined
·
582 Posts
I've never had an up and down reading. However, I pump my gas slowly so that I don't lose fuel due to vapor loss (especially in warm weather). I find the bars will not show full at first. After a few miles it will show all bars to the top.

Patrick
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #13 ·
This is sure an interesting forum. A couple of weeks ago I put on here what the problem was, what the solution was, and how it was doing. Now, those posts are gone. Maybe a glitch? I would sure hope that the forum isn't being censored.
 

·
Registered
Joined
·
315 Posts
I haven't seen anything like this happening... my gas gauge seems just fine... I will keep an eye on it though.
 

·
Registered
Joined
·
271 Posts
I have this problem too. I can top off the tank until it spills over all over my feet and most of the time the top bar of the gas gauge is blank. Occasionally it will be correct and all bars will be lit.
I think it's a Nissan thing because when I had my 06 350Z it did the same thing. Though the gauge was not digital the needle would rarely every go all the way to the top.
 

·
Registered
Joined
·
3 Posts
I have a 2007 Nissan Titan right now and am switching to a Cube as soon as possible but this is an ongoing issue with some of the Nissan's, My fuel pump has been replaced 3 times already under warranty. It has something to do with the ethanol in the fuel not working with their in tank pumps correctly causing readings to be off.
 

·
Registered
Joined
·
271 Posts
OMG I tried the "don't push the nozzel all the way in, and put the auto pump on the slowest setting" that was suggested on another post.......and......
THEN I was sitting in my car with the windows down thank the lord....and all of a sudden I can hear what seems to be someone pouring water on the ground. So I get out and go around the car and the tank was obviously full because gas was spewing out of the tank. It did not auto stop! So I got gas all over the side of my car and my wheel. So after that I KNEW the tank was full and the gauge STILL had the top bar unlit!! And then after about 5 minutes the top bar lit up.
 

·
Registered
Joined
·
64 Posts
Ok so now that this been brought up...
I have about 6k mls on my 09 and at first all of the bars on would light up after a fill up. Recently though, it seems as though the top bar doesn't light up and occassionally it may light up after some time. Weird but I didn't really think much of it :-\
Now I'm thinking I should inquire about it.
 
1 - 18 of 18 Posts
Top