Nissan Cube Life - Nissan Cube Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a bad blower motor resistor in my 2009 Cube. It is an absolute nightmare getting to it, but I got my replacement and went for it. I was able to disconnect the old one but couldn't get it all the way out so I just went ahead and connected the new one. My fans worked again for about 5 minutes then I smelled a little bit of burning and then they were out again. Any advice?
 

·
Registered
Joined
·
2 Posts
Hey what symptoms did you have when resistor went out? Mine is blowing cold air unless its above 80 degrees F and then it blows erratically (all we it cold but not strong) or not at all. Do you think its the resistor?? Single Mom here, Ill replace it myself if thats what it is for sure, just need some opinions on what it is before buying parts. Thanks!!!
 

·
Registered
Joined
·
659 Posts
Hey what symptoms did you have when resistor went out? Mine is blowing cold air unless its above 80 degrees F and then it blows erratically (all we it cold but not strong) or not at all. Do you think its the resistor?? Single Mom here, Ill replace it myself if thats what it is for sure, just need some opinions on what it is before buying parts. Thanks!!!
Not the resistor, but probably the thermostat or the heat control for the heater. The heat control is probably the simplest to check. I no longer have my Cube, so I can't tell you about the thermostat replacement. Usually, that a fast, simple job.
 
1 - 4 of 4 Posts
Top