2011 Cube Krom A/C issues - Nissan Cube Life - Nissan Cube Car Forums
 
Thread Tools
post #1 of 1 (permalink) Old 11-12-2019, 09:21 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Angry 2011 Cube Krom A/C issues

We have a 2011 Cube Krom with 114K miles on it. About 2 months ago the A/C went out. The shop I took it to replaced the compressor, condenser, dryer, pressure switch and radiator fan. The entire system was flushed and placed on a vacuum and then recharged to factory specifications. When we got the car back the A/C was blowing cold. Then it started to work intermittently. It would blow cold while driving it. We turn the car off and when we got in to leave the compressor would kick on for a few seconds and then shut off. Other times it would not come on at all. The shop has checked all of the pressures and they reported they are within normal ranges. It does have Automatic Climate Control. Thinking it may be a sensor. Has anyone else experienced this issue and if yes how did you fix it?
Corytrn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Cube Life - Nissan Cube Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome