My Factory Radio Has No Power - Nissan Cube Life - Nissan Cube Car Forums
 
Thread Tools
post #1 of 1 (permalink) Old 03-23-2019, 07:37 PM Thread Starter
Junior Member
 
Join Date: Mar 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
My Factory Radio Has No Power

My husband was installing speakers and amp, now my radio has no power, the door open light is on and the passenger air bag light is on. Does anyone know what could be wrong? We've checked all the fuses.
Shamus15 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Cube Life - Nissan Cube Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 S Model with Factory Radio/Installed Pioneer AVIC-X920BT pixiedrea Electronics 4 03-18-2012 04:25 PM
factory radio wanted!!!! myfirstcube Personal for Sale/Wanted 3 07-23-2010 08:09 AM
FS Cargo Organizer, OEM cube grill, 2009 factory krom radio ans IPOD connector chompsticks Personal for Sale/Wanted 5 04-15-2010 02:23 PM
Question about replacing the factory radio/ radio signal molejao43 Electronics 1 01-17-2010 07:44 PM
Can I hook up a aftermarket subwoofer to the factory radio? pork n bomb Electronics 7 08-24-2009 06:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome