Acceleration Issue - Nissan Cube Life - Nissan Cube Car Forums
 
Thread Tools
post #1 of 1 (permalink) Old 08-19-2019, 06:47 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: Sydney
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Acceleration Issue

Hi guys, I have a 2004 Nissan Cube. It has done 150,000 kilometres. I bought it second hand and everything has been good for 8 months. 2 weeks ago the acceleration died on me. There is a severe lack in power. I push the pedal down FULLY to go up a hill and it will go about 30kph. Going down hills and on flats I can hit 80 but even then its maxing out. Has anyone else had similar issues? Ive changed the air filter but that has not worked. Every now and then the power will suddenly come back.

Thank you
Harrykimura is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Cube Life - Nissan Cube Car Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome